15883333733
帮助中心

常见问题

LuNamp2.6开源(GPL)发布 不再支持FreeBSD

发布于:2012-08-16 12:57:32  点击量:


LuNamp是网站环境的自动化安装包,傻瓜化一键安装,支持源码安装和rpm二进制安装(使用rpm安装PHP+MySQL环境只需要几分钟),是具有6年多历史的FAMP的后续版本。目前支持的系统有Debian/CentOS/REH/Ubuntu系列(包括KUbuntu, 深度linux, 雨林木风Linux等)

遗憾的提示:在此之前的版本都是支持FreeBSD系统的,但由于开发难度较大等原因,从本版本开始,暂时不再支持FreeBSD系统,希望各位用户谅解!

#----- LuNamp2.6包含的组件

PostgreSQL(数据库), Bind(智能DNS), Apache, MySQL, Nginx, Perl, PHP, pure-ftpd, Memcached, Eaccelerator, GD, Rsync, ZendOptimizer等软件组成的

#------与LuManager高度兼容

LuManager是LuNamp的网页管理软件,通过它可以在线管理Linux/Unix服务器,快速安装Discuz、Phpwind、ECShop、Dedecms、Xweibo、Iweibo、PHPCMS、ECMS等PHP+MySQL架构的软件,5秒内即可创建一个网站!使创建网站的门槛大大降低。官方网站:http://www.zijidelu.org/forum-6-1.html

演示网站:http://demo.zijidelu.org:8888,用户名:zijidelu,密码:zijidelu

#----- 遵循GPL开源协议发布

意味着任何人都可以在遵循GPL开源协议的前提下复制、更改和再发布,从今天开始,您也可以轻易发布自己的服务器一键安装包了!

GPL协议翻译版:http://www.zijidelu.org/thread-2940-1-1.html

GPL协议英文版:http://www.gnu.org/copyleft/gpl.html

#-------包括全自动编译安装和半自动编译安装

全自动安装(即一键安装,执行LuNamp2.6目录下的./i.sh -y便可)包含Apache,选择半自动安装时(./i.sh,不加-y参数),可以选择是否安装Apache,即可以只安装Nginx(LNMP)。不管是全自动还是半自动安装,都比手动配置环境要快,并且不会遗漏相关配置(长时间不配置系统,往往丢三落四的)

#--------升级组件异常方便

拿升级Nginx为例:解压LuNamp_last.tar.gz后,上传新的nginx源码包到LuNamp/soft目录,然后执行LuNamp/code/目录下的nginx.sh再加版本号便可以升级nginx(./nginx.sh “1.0.15” “-y”)。其它软件,如MySQL,Apache等也可以用此方法升级!

升级MySQL:先下载mysql的tar.gz压缩包放到LuNamp/soft目录下,然后切换到LuNamp/code目录,再执行以下代码即可升级。其中的“版本号”用mysql的具体版本代替,如“5.1.63”  ./mysql.sh “版本号” “-y”

#------------------ 安全性和稳定性强

LuNamp基于安全稳定的Linux系统,常见的windows病毒和木马对该类系统无任何作用

#------------------ 下载、安装和卸载

#--------- 下载:

下载网址:http://code.googlecode.com/files/LuNamp_last.tar.gz

更多RPM二进制安装包请前往http://code.googlecode.com/查看

#--------- 安装LuNamp:

1. 解压LuNamp_last.tar.gz:tar -zxvf LuNamp_last.tar.gz

2. 进入LuNamp目录:cd LuNamp

3. 执行安装:./i.sh -y(如果需要选择安装,请使用./i.sh,不加-y参数)

4. 如果是选择半自动安装,则会跳出选项框,选择1,将全部安装,选择2即卸载,选择3,便不安装Apache(LNMP或FNMP)

#--------- 使用二进制包安装LuNamp:

1. 下载rpm二进制包:wget http://code.googlecode.com/files/LuNamp_last.x86_64.reh6.rpm

注意:如果您的系统是centos5,并且是32位的系统,那么二进制包则是LuNamp_last.i386.reh5.rpm

2. 安装rpm包:rpm -ivh --nodeps --force LuNamp_last.x86_64.reh6.rpm

3. 如果您的系统不是精简过的,一般重启即可使用,如果是精简过的,请重启后安装一下环境包:

yum -y install gcc gcc-c++ bzip2 make vixie-cron flex ncurses-devel wget patch ntp libxml2 libxml2-devel libevent m4 autoconf zip unzip libjpeg libjpeg-devel gd gd-devel freetype freetype-devel libpng libpng-devel openssl openssl-devel file libtool libtool-libs gmp-devel pspell-devel parted zlib perl mod_perl-devel apr-util ftp readline-devel curl curl-devel openssh-clients

#--------- 卸载LuNamp:

1. 解压LuNamp_last.tar.gz:tar -zxvf LuNamp_last.tar.gz(如果已经解压了,则略过)

2. 进入LuNamp目录:cd LuNamp

3. 执行安装:执行./i.sh,然后选择2,即可卸载LuNamp

#------------------ 软件操作相关

* 关闭所有组件:lu-stop

* 启动所有组件:lu-start

* 重启所有组件:lu-restart

* 关闭MySQL:mysql-stop

* 启动MySQL:mysql-start

* 重启MySQL:mysql-restart

* 关闭Bind:bind-stop

* 启动Bind:bind-start

* 重启Bind:bind-restart

* 关闭Nginx:nginx-stop

* 启动Nginx:nginx-start

* 重启Nginx:nginx-restart

* 关闭apache:apache-stop

* 启动apache:apache-start

* 重启apache:apache-restart

* 关闭pureftpd:pureftpd-stop

* 启动pureftpd:pureftpd-start

* 重启pureftpd:pureftpd-restart

* 关闭所有组件:lu-stop

* 启动所有组件:lu-start

* 重启所有组件:lu-restart

* 计划任务脚本文件:/usr/local/LuNamp/cmd/crontab_cmd.sh

点击这里给我发消息
业务咨询
点击这里给我发消息
技术支持
点击这里给我发消息
主机域名
点击这里给我发消息
400电话
点击这里给我发消息
售后服务